Was vorstellbar ist, ist auch machbar.
Kostenfrei: 0800 - 54 800 54

typo3

Typo3 TemplaVoila installieren (Installation Teil 1)

Vorabarbeiten:
Eine Seitenstruktur muss vorhanden sein, also einfach ein paar Seiten anlegen.
css_styled_content und static_info_tables includieren bzw. installieren
Ist static_info_tables noch nicht installiert, bekommt man bei der Installation von TemplVoila die Aufforderung dies zu tun.

Als inkompatibel gelten:

kb_tv_clipboard
templavoila_cw
eu_tradvoila

Um alle vorhandenen Versionen sehen zu können, sollte unter Settings (Ext Manager) noch Enable extensions without review gesetzt werden.

Installation:
Und nun einfach templavoila im Backend installieren.

Als nächstes einen SysFolder anlegen. Dieser muss nun verbunden werden.
Web->Seite->rootpage->Eigenschaften->Options->General Record Storage page
Hier den gerade erstellten SysFolder auswählen.

Sollte unter Web->Template->Setup noch

page = PAGE
page.10 = HTML
page.10.value = <div>www.multimediateam.com</div>

stehen, dieses in:

page = PAGE
page.typeNum = 0
page.10 = USER
page.10.userFunc = tx_templavoila_pi1->main_page

Damit bekommt TemplaVoila die Anweisung die Ausgabe zu übernehmen.
Bei dieser Gelegenheit nocheinmal kontrollieren, ob wirklich auch css_styled_content eingebunden ist (Click her to edit whole Template unter Setup zu finden)

Um das Mapping geht es in einem neuen Artikel, alle CSS- und HTML-Dateien (und was sonst noch so gebraucht wird) in einem Verzeichnis unterhalb von fileadmin ablegen. Als Tipp noch an dieser Stelle: ich habe mir den Unterverzeichnis templates hierfür reserviert, da ich mit anderen Namen vor einiger Zeit Probleme hatte. Seither habe ich es mit anderen Verzeichnisnamen nicht nocheinmal versucht. 😉

18 Kommentare to “Typo3 TemplaVoila installieren (Installation Teil 1)”

  1. avatar

    Also ein Tutorial „TemplaVoila installieren“ zu nennen
    und dann einfach
    „Installation:
    Und nun einfach templavoila im Backend installieren.“ zu schreiben,
    finde ich extrem dürftig.
    Einem Anfänger wie mir erschließt sich dadurch nicht, welche extension da im Erweiterungsmanager gemeint sein könnte,
    Vielleicht etwas aus dem Backend? Oder aus den Backend Modules? Oder …..?

  2. Hallo RolWg

    Die Extension heißt ‚templavoila‘ und ist unter ‚Miscellaneous‘ im ‚Extension Manager‘. Für einen Anfänger ist Templa Voila weniger geeignet, da hier gleich mehrere Dinge richtig ineinander greifen müssen. Die Lernkurve ist sehr steil, man muss also viel wissen und verstehen, bevor man eine Ausgabe bekommen kann.
    Die Vorteile von Templa Voila sind allerdings des Lernens wert, da man danach beliebige Layouts umsetzen kann und sich nicht mehr den Einschränkungen von Typo3 unterwerfen muss.
    Als ich diesen Eintrag hier geschrieben habe, dachte ich an einen kleinen Spickzettel, der ein gewisses Grundwissen vorraussetzt. Ich bin also immer dankbar für Anregungen, die es mir leichter machen, mich in die Probleme Anderen versetzen zu können und werde versuchen auch auf diese Fragen ein zu gehen, wenn es meine Zeit zuläßt. Konnte ich denn hiermit die Frage zu meinem Beitrag ausreichend beantworte?

  3. avatar

    Hallo,

    ich habe es installiert und auch gemappt etc. Es läuft auch alles wunderbar, nur beim erstellen eines neuen Elementes, finde ich nicht die Auswahl von flexiblen Inhalt. Sondern nur die Reiter Typischer Seiteninhalt, Spezielle Elemente, Formulare und Plug-Ins.

    Was ist falsch? Was muss ich noch machen?

    Gruß

  4. Hallo Jens

    Hilfreich ist immer die Angabe von Versionen (TYPO3 und Templavoila), ich versuche es mal ohne diese Angabe.
    Beim Mappen gibt es zwei Möglichkeiten, Seitenvorlagen und Inhaltsvorlagen.
    Nur die als Inhaltselemente gemappten Elemente erscheinen als FCE (Flexible Content Elemente). Ich denke hier liegt der Fehler.
    Ich hoffe es hilft schon.

    Viel Erfolg wünscht Dir
    Dirk Jüttner

  5. avatar

    Danke für deine Antwort.

    templavoila.wizards.newContentElement.wizardItems.fce.show = fce_17
    Bin noch auf das gestossen, muss dieser im Setup ebenfalls stehen? Habe es mal hinzugefügt, auch die ID verbessert, doch hat auch nichts gebracht.

    Bin noch absoluter typo3 empfänger. Deshalb schildere ich es mal haargenau, was ich jetzt tu. Ich geh auf Web -> Liste -> General Storage. Wähle im Kontextmenü des TO TempolaVoila und klick auf DS / VO modifzieren.

    Ich habe dort Root als body INNER gemapt. Hab dann ein Element mit Content erstellt, welche ich als Inhaltselement unter „Voreinstellungen Element“ definiert habe. Diesen habe ich auch der div mit der id content gemapt. Inner, versteht sich.

    Mehr habe ich eig auch garnicht gemacht.

  6. avatar

    Sry, die Versionen habe ich vergessen. Es handelt sich um templavoila 1.8.0 und typo3 wäre 6.1.5.

    Danke

  7. Web -> Templavoila wäre die richtige Stelle:
    Dort gibt es einen Tab mit ‚Seiten-Templates‘ hier erscheinen alle Vorlagen die Auf Seiten im Backend angewendet werden können und einen Tab mit ‚Flexible CE‘ hier sind dann Inhaltselemente möglich.
    Nach der Installation von Templavoila muss erst mindestens ein Seiten-Templates gekappt werden, sonst kann im Frontend (FE) bis auf eine Fehlermeldung nichts angezeigt werden. Erst dann können FCE erstellt und ausgegeben werden.

  8. Die Versionen passen schon mal zusammen 😉

    templavoila.wizards.newContentElement.wizardItems.fce.show = fce_17
    Das klingt falsch, ins Setup gehört es nicht.

  9. avatar

    Im Frontend läuft alles wunderbar. Also der Content wird angezeigt, von der aufrufunden Seite. Aber halt untereinander weil die im Backend auch untereinander gelegt sind und ich keine FCE’s auswählen kann.

    Wie kann ich den Seiten-Templates kappen? Oder wo finde ich sie überhaupt…

  10. Wunderbar.
    Hast Du mehrere Seiten-Templates angelegt, wählst Du sie unter:
    Web / Seite / Im Seitenbaum die entsprechende Seite wählen / Seiteneigenschaften / Erscheinungsbild / Vorlagen-Design benutzen

    Hier ist eine Selectbox in der Deine angelegten Seiten-Templates auftauchen.

    Was steht denn unter:
    Web / Templavolia / Storagefolder / Flexible CE
    Hast Du hier auch Elemente? Diese sollten dann als Inhaltselemente wählbar sein. Wenn nicht, stimmt was mit Deinem Sysfolder nicht. Dieser sollte in der Rootseite als ‚Allgemeine Datensatzsammlung‘ gewählt sein. Alle Templavoila-Vorlagen (Seiten-Vorlagen und FCE) sollten dann als pid die id dieses Sysfolder haben.

  11. avatar

    Nochmals hallo,
    im Root unter Allgemeine Datensatzsammlung ist der Ordner schon ausgeählt. Das Problem war, dass ich das Template komplett selber gemacht habe und es gar keine FCE-Templates gab. Ich habe zur Testzwecken 50-50 (Jeweils 2 divs mit float und width 50%) und 33-33-33 erstellt. Und siehe da es funktioniert nun. Habe auch RealUrl installiert. Jetzt muss ich das nur noch mit dem Language hinbekommen.
    Danke dir 🙂

  12. Freut mich, wenn ich helfen konnte.
    Die Übersetzungen sind in TYPO3 6.1.5 nicht mehr im Extensionmanager, sondern unter Admin Tools / ‚Language‘.
    Hier einfach die gewünschten Sprachen wählen und dann ganz oben auf der Seite auf ‚Update from repository‘ klicken. Fertig.

  13. avatar

    Hallo Dirk,
    die Rede war von Multilanguage, was Übersetzungen betrifft. Habe es nun aber auch hinbekommen, doch irgendwo scheitere ich.

    Ich habe als Standard de festgelegt im Root und es gibt noch die zusätzliche Sprache.

    Gebe ich dem Link ?L=1 als GET Parameter bei funktioniert es wunderbar, doch auch erscheint dort ein Content, welches keine Übersetzung hat, und somit die deutsche Version angezeigt wird.

    Was mich wundert, ist folgender, denn ich habe als Sprache nicht Alle sondern Standard ausgewählt, damit es nur auf Standard angezeigt wird, aber er zeigt es, sobald keine Übersetzung vorhanden ist auch bei der zweiten Sprache an. Dafür gäbe es ja Alle zur Auswahl.

    Habe ich evtl. irgendetwas in der Config vergessen?

    Hast du evtl. eine Ahnung? `
    Meine Config:
    page {
    config {
    # LANGUAGE
    linkVars = L
    sys_language_uid = 0
    language = de
    locale_all = de_De
    sys_language_overlay = 1
    sys_language_mode = content_fallback
    }
    }

    [globalVar = GP:L = 2]
    page.config{
    sys_language_uid = 2
    language = pl
    locale_all = pl_PL
    htmlTag_langKey = pl
    }
    [global]

  14. Hier ist die Mehrsprachigkeit bei TYPO3 kein Thema, der einzige Eintrag zu dem es halbwegs passen könnte steht unter:
    https://www.kigmbh.com/2009/09/typo3-einsprachige-website-von-englisch-auf-deutsch-umstellen/
    Mal sehen ob wir es kurz hier einschieben können.

    Um in TYPO3 für das FE (Frontend) Sprachvarianten anzulegen ist der erste Schritt, diese in der Ebene vor der Rootpage (Wurzelseite mit der Weltkugel als Icon) hinzufügen. Also die Seite mit der ID = 0 (nicht die Weltkugel mit ID = 1 oder größer) in der Listenansicht anzeigen: Neuer Datensatz / Systemdatensätze / Website-Sprache. Die Felder „Inaktiv“, „Sprache“, „Offizielle Sprache wählen“ und „Flaggensymbol wählen“ ausfüllen.
    Sind alle Sprachen angelegt, können im BE (Backend) Seitentitel und Inhalte mehrsprachig angelegt werden.
    In TYPO3 6.1 ab der Rootpage (und alle Unterseiten) einen neuen Datensatz anlegen: Listenansicht / Systemdatensätze / Alternative Seitensprache / Sprache und Seitentitel eingeben. Inhalte übersetzen.
    Die ID der angelegten Website-Sprache ist die sys_language_uid. Hier prüfen ob „Englisch“ wirklich die 1 und in Deinem Fall „Polnisch“ wirklich die 2 hat.

    Mit:

    config.metaCharset = utf-8
    config.linkVars = L
    config.sys_language_uid = 0
    config.language = de
    config.locale_all = de_De
    config.htmlTag_langKey = de-DE

    bekommt man „Deutsch“ als Grundeinstellung.

    Mit:

    [globalVar=GP:L=1]
    config.sys_language_uid = 1
    config.language = en
    config.locale_all = en_UK
    config.htmlTag_langKey = en-UK
    [global]

    wird „Englisch“ als zweite Sprache ausgegeben u.s.w.
    Die Schalter:

    config {
    sys_language_mode = content_fallback
    sys_language_overlay = 0 | 1 | hideNonTranslated
    }

    bilden weitere Möglichkeiten der Konfiguration ab und sind optional.
    Hier steht in der offiziellen Dokumentation welche Werte sich wie verhalten und welche Kombination den gewünschten Effekt erzielt.

    Ich muss gestehen Dein Problem nicht vollständig verstanden zu haben. Du musst Dir folgend Frage beantworten können:
    Was soll geschehen, wenn Seiten oder/und einzelne Inhalte nicht übersetzt sind. Erst dann würde ich die Einstellungen sys_language_mode und sys_language_overlay setzen. Kommentiere sie einmal mit einer „#“ aus:

    config {
    # sys_language_mode = content_fallback
    # sys_language_overlay = 1
    }

    und prüfe, ob sich das Verhalten ändert.
    Bedenke: Ist eine Übersetzung nicht vorhanden, kann sie nicht angezeigt werden.

  15. avatar

    Hallo,

    danke. Falls für die Webseite keine Übersetzung vorhanden ist, will ich dass die 404 Fehlermeldung erscheint, falls die Seite vorhanden ist aber einzelne Inhalte nicht vorhanden sind auf der Sprache, soll nichts von der Standardsprache übernommen werden. (Dies habe ich auch hinbekommen). Nur die Seite,falls die gwünschte Sprache in der Alternativen Sprache nicht vorhanden ist, soll sie auch nicht angezeigt werden, auch wenn Inhalt da sein sollte.

  16. Mögliche Einstellungen für sys_language_mode sind:

    config.sys_language_mode = default | content_fallback | strict

    Sorry, hatte ich in meiner Antwort nicht geschrieben.

    In Deinem Fall könnte:

    config.sys_language_mode = strict; 0
    config.sys_language_overlay = hideNonTranslated

    die Lösung sein.

  17. avatar

    Genau, dass war es auch. Findet man die Lösung kommt nun ein neues Problem. Diesmal erscheint wie gewollt die Fehlermeldung bei Impressum (Keine Übersetzung vorhanden in Englisch), sobald ich diese aufrufen will fürs englische.

    Aus dem Menü ist auch Imprint verschwunden, nachdem ich die Alternative-Sprache dafür gelöscht hatte. Doch nun steht dort Impressum auf Deutsch (Standardsprache). Die Verlinkung geht jedoch auf /en/impressum/. Normalerweise sollte es garnicht im Menü angezeigt werden.

  18. Versuche erst einmal die Einstellung:
    config.sys_language_mode = strict
    also ohne „;0“
    In der Dokumentation Empfohlen ist:
    sys_language_mode = content_fallback
    Zur Frage warum, würde ich Dich auf die Dokumentation verweisen. Entscheidest Du Dich trotzdem für strict, lohnt sich der Blick um so mehr.

    Wie ist denn die Erwartungshaltung?
    1. Eine 404 Seite soll angezeigt werden?
    2. Der Menüpunkt soll erst gar nicht angezeigt werden?
    Ich gehe davon aus, der Cache (BE, Browser, Proxy) ist gelöscht!

    Zu 1:
    Wenn eine 404 Seite angezeigt werden soll, muss diese eingerichtet sein.
    Dazu ist der erste Schritt im Installtool „pageNotFound_handling“ mit einer Seite zu verbinden, die im BE angelegt sein muss. Nur dann kann ich sie dort auch verwalten.

    Zu 2:
    Ist eine Übersetzung der Seite (nicht der Inhalte) angelegt?
    Wenn „ja“, muss diese Übersetzung gelöscht werden.
    Wenn „nein“, könnte es an realurl liegen. Wie ich in Deiner Fehlerbeschreibung lese nutzt Du realurl. Hier muss der Index neu aufgebaut werden. Dazu geht man unter Web / Info auf „realurl Manager“, dort kann der Index eingesehen und neu aufgebaut werden.
    Eine weitere Fehlerquelle könnte auch eine Navigation sein, die nicht mehrsprachig ist. Dazu wäre die Frage wo der Link auftaucht, also wie er generiert wird zu stellen. Ist es die Funktionalität von Typolink, die verantwortlich für den Link ist? Ist es eine Extension, oder gar hardcoded?

    Die häufigsten Fehler sollten dabei gewesen sein, vollständig ist die Liste nicht.

    Allgemein gilt:
    Vergleiche mit der Dokumentation noch einmal Deine Erwartung mit der Beschreibung zu sys_language_mode und sys_language_overlay. Hast Du hier wirklich eingestellt, was Du haben möchtest, dann geht es mit Punkt 1 und 2 weiter. Auch bei Punkt 2 realurl sollte erst das Manual gesichtet werden. Nur wenn die Grundkonfiguration richtig ist, lohnt eine Fehlersuche.

    Wenn sich der Fehler noch nicht gezeigt hat, hilft es die Komplexität zu verringern:
    – Schalte die Sprachen der Reihe nach ab. Sprachen auf inaktiv setzen.
    – Schalte realurl ab.
    – Schalte Extensions ab, die Einfluss haben (könnten).
    Welche Links werden generiert? Sind diese schon falsch, liegt der Fehler tiefer. Stimmt noch alles, schaltet man die Features einzeln wieder zu bis der Fehler auftaucht.

    Von Templavoila sind wir inzwischen weit weg.

Schreiben Sie einen Kommentar

*